Vuforia App Key

December 19, 2014 - 2:54am #1

I'm trying the iOS samples however, when running the app, I get "Vuforia App key is missing. Please...". Where do I enter the App key? I can't find it in the code.

Vuforia App Key

February 10, 2015 - 11:24pm #13

Some additional notes:

- you can download the latest Vuforia 4.0.11 beta that was released on February 06 (this introduces several enhancements w.r.t. the previous 4.0.5 released in December)

- when copying the License Key from the License Manager, make sure no extra/blank spaces are appended at the beginning/end of the key string

- it appears that on Firefox browser there may be some issues when using the "Copy To Clipboard" button, so, you can try using a different browser or manually copy the license key by selecting it via mouse drag (again, paying attention to not accidentlly include any extra space)



Vuforia App Key

February 10, 2015 - 1:07am #12

@ dfelber:

if you have issues with the License Key creation upon logging in with your account, you can send an inquiry to:

(please specify that the issue is about the 4.0 Beta )

Vuforia App Key

February 5, 2015 - 11:59pm #11

I would also love to upgrade to Vuforia 4 beta - but I can't even create an App Key at

It does not say anything after I entered my email/password - just redirects me to the same page over and over again.

Login data must be correct, or I wouldn't be able to download the unitypackage of the beta.

Vuforia App Key

January 20, 2015 - 9:27am #10

Can you PM me your App name and App License Ley, so that we can verify internally ?

Vuforia App Key

January 20, 2015 - 7:26am #9

When i use the play mode it works . But when i tried it to my device that thing is showing up(the invalid key message).

Vuforia App Key

January 19, 2015 - 11:47am #8


is this happening in Play Mode or when running on device ?


Vuforia App Key

January 17, 2015 - 8:45am #7

Yes my internet connectivity is On . But still i'm getting this "Invalid key used. Please make sure you are using a valid Vuforia App key" .. I Doubled check my keys and they are perfectly correct.

Vuforia App Key

January 17, 2015 - 8:40am #6

Have you checked that your internet connection is enabled ?

Vuforia App Key

January 17, 2015 - 5:28am #5

i already put may license key in Arcamera .. but I'm getting Invalid Key although i paste the right key. I don't know what is the problem.

Vuforia App Key

December 19, 2014 - 12:52pm #4

In Unity, you can simply copy-paste the key into the license key field in the ARCamera inspector view, in the Unity Editor. If you have a valid key, this should work.


Vuforia App Key

December 19, 2014 - 9:23am #3

Cool, I eventually found this link.

It works for the iOS apps, however I tried it with the Penguin Unity app, but I keep getting a "Vuforia App key is missing." when I did add it ARCamera file. Any ideas?

Vuforia App Key

December 19, 2014 - 5:01am #2


You can enter it in:

QCAR::setInitParameters(mQCARInitFlags,"<Your app key>")

in initQCARInBackground method.

Topic locked