Network Connection error in Unity Play Mode

January 28, 2015 - 9:43pm #1

Hello, I'm having the exact same problem as the closed thread regarding Unity Play Mode not being able to connect. My Android device on the same network has no issues, and its a private network with no site blocking and I even tried turning off all firewalls. This happens in an empty scene with just the new camera as well as in fully set up projects. Any help wpuld be appreciated. 

 

 

Network Connection error in Unity Play Mode

June 9, 2015 - 11:46am #42

HudaAtef wrote:

I using unity4.6 , vuforia 4.0.5 beta .

The 4.x beta versions of Vuforia connected to a beta-only server to authorize beta keys. That server has been shut down and that is why you are receiving a connection error. The beta ended in late February with the commercial release of Vuforia 4.0.103. The current version of Vuforia is 4.2.3 and no longer requires an Internet connection to validate the license key.

Network Connection error in Unity Play Mode

June 9, 2015 - 2:44am #41

Hello ,

I am having the similar issue. Whenever, I hit the play button in unity editor and also on my android device , I get this error message  "Unable to contact server. Please  try again later" I have checked everything else is working fine, I have checked my internet connection and also I can go to unity store and download the file. So, I dont think the issue is with connection.

I using unity4.6 , vuforia 4.0.5 beta .

Can someone help me please.

AttachmentSize
Image icon error.png6.06 KB

Network Connection error in Unity Play Mode

April 1, 2015 - 11:08am #40

ibancel wrote:

The link https://developer.vuforia.com/downloads/early doesn't work for me : it redirects me on the home page.

Give it another try.

Network Connection error in Unity Play Mode

April 1, 2015 - 12:32am #39

The link https://developer.vuforia.com/downloads/early doesn't work for me : it redirects me on the home page.

Network Connection error in Unity Play Mode

March 31, 2015 - 10:04am #38

Darzentas wrote:

Hi

 

Thanks, that worked!

However as it is a bit of a hack, espceially for multiple deployments, are there any proper fixes incoming?

 

Thanks again

 

Yes, we will be addressing this in a future Vuforia release.

Network Connection error in Unity Play Mode

March 31, 2015 - 10:01am #37

Hi

 

Thanks, that worked!

However as it is a bit of a hack, espceially for multiple deployments, are there any proper fixes incoming?

 

Thanks again

 

 

 

 

Network Connection error in Unity Play Mode

March 31, 2015 - 9:22am #36

Network Connection error in Unity Play Mode

March 31, 2015 - 9:14am #35

Running on Windows 8. 

Network Connection error in Unity Play Mode

March 31, 2015 - 8:53am #34

Windows 7 SP1 64bit

i've tried both 64 and 32 bit versitons of Unity

Has a correlation been found?

Thanks:)

 

Cheers

 

dm3d wrote:

@AndersBlommaN, @Darzentas: Are you running Unity on Windows or OS X?

Network Connection error in Unity Play Mode

March 31, 2015 - 8:41am #33

@AndersBlommaN, @Darzentas: Are you running Unity on Windows or OS X?

Network Connection error in Unity Play Mode

March 31, 2015 - 8:20am #32

Hi all,

Any updates on this? Vuforia in unity insists that there is no internet connection

It's basically impossible to get any work done. And no, it has nothing to do with the connection on my end

Cheers

Network Connection error in Unity Play Mode

March 31, 2015 - 7:42am #31

im having rly good connection with 100/100 so thats not the problem. :/ 

Network Connection error in Unity Play Mode

March 31, 2015 - 6:32am #30

Open the app with better internet connection for the first time to validate the QCAR License. Next time onwards no need of internet.

Network Connection error in Unity Play Mode

March 31, 2015 - 6:23am #29

My Unity version is 4.6.2f1 Pro and the Vuforia version is "vuforia-unity-mobile-android-ios-4-0-103"

In an empty project I just drag de ARCamera and import my target from Vuforia website. I put de License Key and just play the scene and the same problem appears as earlier posts.

Get the error:

QCAR Initialization Error

No network available. Please make sure you are connected to the internet.

 

any suggestions?

 

Network Connection error in Unity Play Mode

March 26, 2015 - 11:50am #28

If you are:

  • Running Vuforia 4.0 in Unity on Windows
  • Haven't used Cloud Reco prior to Vuforia 4.0 on your machine
  • Are receiving a "QCAR Initialization Error: No network available. Please make sure you are connected to the Internet."

Here's the workaround:

  • Run Cloud Reco 3.0.10 sample app (or other Vuforia 3.x Cloud Reco app) in Unity PlayMode and recognize a target
  • Switch back to Vuforia 4.0 and try running in PlayMode

 

Network Connection error in Unity Play Mode

March 26, 2015 - 11:03am #27

Hi DM3D, can you send me these instructions as well? My license key is perfect, on the bronze plan. Please respond quickly, leaving my developers shortly.

Network Connection error in Unity Play Mode

March 26, 2015 - 10:41am #26

@kevingeorge: Just sent you a PM with instructions.

Network Connection error in Unity Play Mode

March 25, 2015 - 11:47pm #25

Am having the similar issue. Whenever, I hit the play button in unity editor, I get this annoying error message "Unable to contact server. Please  try again later" I have checked everything else is working fine, I have checked my internet connection and also I can go to unity store adn download the file. So, I dont think the issue is with connection.

Can someone help me please.

Network Connection error in Unity Play Mode

March 23, 2015 - 11:13am #24

@tomwim, @TheWolfmage: Just sent you PM with instructions.

Network Connection error in Unity Play Mode

March 23, 2015 - 11:05am #23

@igorlean: Just sent you a PM with instructions.

Network Connection error in Unity Play Mode

March 23, 2015 - 10:51am #22

Feraligatr wrote:

Hi,

- I'm using unity 5 32 bit on windows 7

- I'm running vuforia test scene for object recognition (teapots)

- I checked the code a thousand times and it does not contain whitespaces

- I have a working internet connection with no proxies or whatever can bluck the connection, unity is also successfully checking for updates

- I still get the annoying "no network connection" error 

Please help :/

@Feraligatr: Just sent you a PM with instructions.

Network Connection error in Unity Play Mode

March 23, 2015 - 4:35am #21

Am also facing the same problem without internet for the first time.

my Solution : 

For the first time app should open with better internet connection to validate the license. Once validated, no need of internet. 

Network Connection error in Unity Play Mode

March 23, 2015 - 2:00am #20

Any news about the solution of this issue?

Network Connection error in Unity Play Mode

March 20, 2015 - 6:39pm #19

Hello for all,

I just found this post with the same problem that I have right now. 

My Unity version is 4.6.2f1 Pro and the Vuforia version is "vuforia-unity-mobile-android-ios-4-0-103"

In an empty project I just drag de ARCamera and import my target from Vuforia website. I put de License Key and just play the scene and the same problem appears.

QCAR Initialization Error

No network available. Please make sure you are connected to the internet.

Of course Unity is connected to internet because I can open the Asset Store inside Unity. So I understand that there is no problem between Unity and any firewall.

I also have check a lot of times that the license key is without any blank space or somehing. I hace copy it using Chrome and IExplorer and paste in Unity editor. The same problem.

I have tried to type manually the license key character by character, but the same problem happens.

Please, could anyone help me?

 

thank you very much for all

Igor

 

Network Connection error in Unity Play Mode

March 20, 2015 - 3:49pm #18

Having the same issue.  Tried all the suggestions below and in other posts on the topic.  What was the solution???

Network Connection error in Unity Play Mode

March 20, 2015 - 7:37am #17

seen and answered, but you should really post that as a public official solution if it works... for now :/

Network Connection error in Unity Play Mode

March 20, 2015 - 7:35am #16

See my PM to you.

Network Connection error in Unity Play Mode

March 20, 2015 - 6:57am #15

I already read this thread and there's nothing in there that i didn't try, of course i checkd for this, i even entered the code manually letter-by-letter, to see if that changed something...

and just for curiosity, i tried this in unity 64bit and it dosn't have this issue (it validates the code), but of course then vuforia doesn't work because it only supports unity 32bit

Network Connection error in Unity Play Mode

March 20, 2015 - 6:38am #14

Try to copy the string to a Text editor and verify that you do not have hidden "newline" or "carriage return" characters at the end of the string, as these can have the same effect as "blank" spaces.

 

Network Connection error in Unity Play Mode

March 20, 2015 - 6:24am #13

Hi,

- I'm using unity 5 32 bit on windows 7

- I'm running vuforia test scene for object recognition (teapots)

- I checked the code a thousand times and it does not contain whitespaces

- I have a working internet connection with no proxies or whatever can bluck the connection, unity is also successfully checking for updates

- I still get the annoying "no network connection" error 

Please help :/

Network Connection error in Unity Play Mode

February 27, 2015 - 7:57am #12

Could you try to deploy and run on device and see if it is Play Mode specific, or happens in device too ?

 

 

Network Connection error in Unity Play Mode

February 27, 2015 - 7:51am #11

I'm using Unity 4.6.2f and used Chrome (and IE) to grab the License Key. I haven't had the chance to deploy to a device yet, so I'm just using Unity. So I guess the time/date issue isn't the problem. Time and date is fine and I highly doubt that another time zone causes any problems.

Console Output is attached.

Thanks again!

AttachmentSize
Image icon Error.PNG7.14 KB

Network Connection error in Unity Play Mode

February 27, 2015 - 7:25am #10

Also make sure your device has approximatly the correct time/date.  If this is extremely off, then the SSL verification can fail.

Network Connection error in Unity Play Mode

February 27, 2015 - 7:16am #9

Could you grab the Unity console Logs and paste them here ?

Also, which Unity version are you using ?

and what Web browser you used to display the License Manager page with your Key ?

 

Network Connection error in Unity Play Mode

February 27, 2015 - 6:40am #8

Thanks for the quick reply.

Unfortunately it still doesn't work. 
How would you make sure that there is absolutely no unwanted character in the copied license key?

Network Connection error in Unity Play Mode

February 27, 2015 - 4:59am #7

Could you try the following:

- close Unity

- remove the /Library folder under your Unity project

- reopen Unity (your project)

- remove the Key from the ARCamera and copy-paste it again (from the License Manager into the ARCamera)

- run ?

 

Network Connection error in Unity Play Mode

February 27, 2015 - 4:02am #6

Hi,

I'm having the same problem. 
I just downloaded the Vuforia Unity Extension today, so it should be the newest version.

A lot of people with the same issue reported a license key copy problem with blank spaces. I checked for blank spaces, copied it in a text editor to scan for other weird characters but the license key should be fine. I'm also connected to the internet and can access vuforia.com.
I followed the instructions in the closed thead: https://developer.vuforia.com/forum/general-questions/unity-play-mode-network-error
Still the error message: "QCAR Initialization Error. No network available. Please make sure you are connected to the internet."
I'd really like to make this run so I hope someone can help me!

Thanks in advance

Network Connection error in Unity Play Mode

February 10, 2015 - 1:14am #5

You may also want to try the latest Vuforia 4.0.11 Beta just released few days ago, to see if it makes a difference:

https://developer-beta.vuforia.com/

 

Network Connection error in Unity Play Mode

February 5, 2015 - 3:02pm #4

Make sure your device/machine has a more or less proper time & date.  If it is several weeks or months off of the true date, the verificaiton of the SSL certificate will fail.  This will present itself as an "unable to connect to server" error.

Network Connection error in Unity Play Mode

January 29, 2015 - 8:48am #3

And what is the error message you get in Play Mode ? 

Is it "No network connection" or "Invalid keys" ?

 

Network Connection error in Unity Play Mode

January 29, 2015 - 2:20am #2

Hi, would you mind sending me your App name and key via PM ?

 

Log in or register to post comments