Topic locked

Unity 5

March 3, 2015 - 1:28pm #1
Today Unity 5 is released and I tried Vuforia 4.0 with the new Unity.
That's what I saw in the editor -
 
Failed to load 'Assets/Plugins/QCARWrapper.dll', expected 64 bit architecture (IMAGE_FILE_MACHINE_AMD64), but was IMAGE_FILE_MACHINE_I386.
Vuforia.WebCamAbstractBehaviour:CheckNativePluginSupport()
 
So, we wait Vuforia 4.1

Unity 5

April 21, 2015 - 4:49am #37

You're welcome.

Unity 5

April 21, 2015 - 4:38am #36

Thanks! You saved my life!

I had no idea about this

All I did was to set the QCARWrapper.bundle like the image I attach.

;)

Unity 5

April 21, 2015 - 3:37am #35

See the "Tips" section in this post:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/vuforia-40-and-unity-50

That should solve the issue.

 

Unity 5

April 21, 2015 - 3:34am #34

As AlessandoB says, here we have the same problem:

Using Unity 5 and Vuforia 4_0_105 and trying to export an IPA for AdHoc from Xcode 6.3 does not work, and exporting an IPA from the command line makes the app stuck when installing on an iPad form iTunes.

If anyone got it working, it would be nice to share the answer.

I hope the Vuforia team solves this issue as fast as possible.

Unity 5

April 17, 2015 - 9:48am #33

Thank you for the guide, I am able to fix it using the upgrade steps. Cool!

 

Unity 5

April 17, 2015 - 6:21am #32

See the migration guide steps here:

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

we tried the same upgrade exercise (from 4.0.103 to 4.0.105) using the steps described above and they worked just fine.

Hope this helps.

 

Unity 5

April 17, 2015 - 6:06am #31

Update from vuforia 4.0.103 to 4.0.105 (support Unity 5 in play mode) does not work. what I did was import the new package 4.0.105 on the existing project that already has 4.0.103 and then ged rid the redundant files generated under plugins folder. It would be nice if the import do this job instead of generate another version of the files and add "1" at the end of file names. But all of that effort still won't work. Can't play in unity.

Any idea?

Thanks

Unity 5

April 16, 2015 - 9:48am #30

We tested Unity 5.0.1f1 and 5.0.1p1 with Vuforia 4.0.105 and we were able to build and deploy on iOS targets, on Xcode 6.2 and 6.3.

(note: the Graphics API settings must be set to OpenGLES 2.0, and the Scripting Backend must be set to IL2CPP; these Player Settings should be already set automatically when Vuforia is imported into the project, but you may want to double-check them).

 

There are a few known issues mentioned in the Release Notes:

https://developer.vuforia.com/library/articles/Release_Notes/Vuforia-40-SDK-Release-Notes

In particular there is a known Editor crash that can be triggered when clicking on an Image target in the Image target sample scene:

  • The Unity 5.0 editor crashes when an ImageTarget prefab instance in the ImageTargets sample is selected prior to selecting another prefab in the hierarchy when the sample is first loaded. Selecting an alternate prefab, such as the ARCamera, after initially loading the sample scene will prevent this crash from ever occurring. 

As mentioned above, if you click on the ARCamera before clicking on an Image Targets, this will prevent any subsequent click from causing any editor crash. Note that this crash seems to be affecting the Image targets sample scene and according to our tests it should not affect a freshly created new Image target (i.e. dragged into the scene from the Prefabs folder).

 

If the issue above does not represent what you are seeing, could you describe the steps to trigger the crash and your system specifications ?

 

 

 

Unity 5

April 16, 2015 - 9:20am #29

I tries this update Vuforia 4.0.105 within Unity 5 and crashes in the editor and gaves me a codsigned fail error once i tried to create my ipa file once in xcode 6.

I don't it does not work in the editor but i cannot understand why id not export! Has it been tested to the level it export to IOS devices?

Someone even discribed a way to create your ipa manully (thourgh terminal) without using xcode. Seems nice way to get around the problem but at the end the app does not install properly. Very nice work though. http://tangochen.com/blog/?p=2057

I need to sort out this issue ASAP.

As long time user of Vuforia and with the payment scheme that Vuforia has come up with (over 100 / month + extras for recognition usage after 5K) and all the time that we need to fgure all these issues, it becomes an even more expensive  platform and a very questionable option to deliver AR solutions to clients!

Thanks

Rick

Unity 5

April 15, 2015 - 12:55pm #28

Thanks for the information.

Unity 5

April 15, 2015 - 12:05pm #27

Vuforia 4.0.105 with Unity 5.0 support on Mac OSX (64bit) has just been announced:

https://developer.vuforia.com/forum/news-and-announcements/announcing-unity-50-64-bit-support-mac-os-x

 

Unity 5

April 15, 2015 - 12:05am #26

Hi,

I am trying to create an IOS application on the Mac. I dowloaded the x32 version on PC and recompiled the project.

 

I gave me a bunch of error with librairy files missing. According to some threads, it normally creates this situation with compiling on windows and porting it to MAC.

 

Thanks

Rick

Unity 5

April 14, 2015 - 2:16pm #25

I can't answer to your problem, but there's temporary solution: install unity x32( keep both). Works.
(win7 x64, unity 5 free license.)

Unity 5

April 14, 2015 - 11:57am #24

Hi,

About the 64 bit issue, it says that the sdkv4.0.11 has fixed the issue. Where can i find that fix.

https://developer.vuforia.com/library/articles/Release_Notes/Vuforia-40-SDK-Release-Notes

I am getting this error. I installed previous (Legacy) marker packages. Could be the reason?

Couldn't open /Users/XXXX/Documents/XXXXXX/Assets/Plugins/QCARWrapper.bundle/Contents/MacOS/QCARWrapper, error: dlopen(/Users/XXXXX/Documents/XXXXXX/Assets/Plugins/QCARWrapper.bundle/Contents/MacOS/QCARWrapper, 2): no suitable image found.  Did find:
/Users/XXXXXXX/Documents/XXXXXX/Assets/Plugins/QCARWrapper.bundle/Contents/MacOS/QCARWrapper: mach-o, but wrong architecture
Vuforia.WebCamAbstractBehaviour:IsWebCamUsed()
Vuforia.WebCamAbstractBehaviour:IsWebCamUsed()
Vuforia.QCARRuntimeUtilities:IsQCAREnabled()
Vuforia.TurnOffBehaviour:Awake() (at Assets/Qualcomm Augmented Reality/Scripts/TurnOffBehaviour.cs:21)
 

Thanks

Rick

 

Unity 5

April 14, 2015 - 10:40am #23

If  windows x64 is not supported then logically it's would be easier to use older version of vuforia plugin, but I believe it would be impossible since you need license key even if you don't do commercial stuff.

Unity 5

April 9, 2015 - 9:21am #22

Not yet.

But it will support it soon, normally this is expected in the next release.

 

Unity 5

April 9, 2015 - 8:56am #21

Vuforia is not supporting unity 5 64bit (OSX) yet? 

OR? Will never support unity 5 64bit?

 

Otherwise "may not" is not answer!

Previous version also did not work without ton of patches.

Maybe Qualcomm should invest their license charges to 

better development and support! 

 

Unity 5

March 20, 2015 - 7:40am #20

hey wanquan !!!! im working with unity and vuforia since yesterday and tried a tutorial on youtube!

 

"tutorial on making an android AR scene"

 

i have done everything EXACtLY as the guy in the video but i g0t the SAME "warnings" as you  !!!!!!

 

 

my camera is working perfectly!

then I tried 3 or 4 different image targets...

 

nothing worked

 

i hope someone can help us !!! =(

 

i am working with vuforia 4 and the unity 4.3.6 or something.  I didnt download unity 5 because I read that there are some problems

AttachmentSize
Image icon fehler1.PNG19.29 KB
Image icon fehler2.PNG19.24 KB

Unity 5

March 20, 2015 - 6:06am #19

AlessandroB wrote:

once you land on the Unity 5 download page,

you should see a dropdown menu with title "Additional Downloads" and sub-header "For Windows"; for there you can download the 32bit version called "Unity Editor (32bit)".

 

I downloaded unity 4 now but thank you =)

 

I opened a new thread 10 minutes ago . it would be awesome if you could take a look =)

 

https://developer.vuforia.com/forum/ar-technical-discussion/creating-ar-trackables 

 

cheers =)

Unity 5

March 20, 2015 - 4:04am #18

I installed the 32bit unity version on windows (7) and after importing the fully working project in unity i still got this error:

MissingMethodException: Method not found: 'UnityEngine.Component.get_renderer'.
ImageTargetEditor.UpdateMaterial (IEditorImageTargetBehaviour it)
ImageTargetAccessor.ApplyDataSetAppearance ()
SceneManager.UpdateTrackableAppearance (.TrackableBehaviour[] trackables)
SceneManager.EditorUpdate ()
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at C:/buildslave/unity/build/artifacts/generated/common/editor/EditorApplication.gen.cs:268)
 
That goes on even without starting the play test
What's wrong?

Unity 5

March 20, 2015 - 12:01am #17

Hi,

I've used to do some experiments with vuforia on the older versions.

Lately I installed unity5 without researching that vuforia doesnt support unity5 on mac.

After installing unity 5 and vuforia 4, my project doesn't work.

Now that I've come to know about this issue, I've reinstalled unity back to 4.5.5 with vuforia 4.

However, I am still unable to get vuforia working. I'm using the sample scene which use stones_scaled.jpg

1. Camera works but does not detect images.

2. It says "trackable stone lost" when I run my project.

Can anyone tell me what I can do to make vuforia run properly?

Thanks a million!!

Unity 5

March 19, 2015 - 11:41pm #16

once you land on the Unity 5 download page,

you should see a dropdown menu with title "Additional Downloads" and sub-header "For Windows"; for there you can download the 32bit version called "Unity Editor (32bit)".

Unity 5

March 19, 2015 - 8:34pm #15

can someone give me a link where I can download the 32 bit version for windows???

Unity 5

March 19, 2015 - 2:56am #14

Quote:

You may use Vuforia 4.0 with the Windows 32 bit version of Unity 5, but not on Mac (which requires a 64bit version).

Hey, thanks for replying today. Im using mac for iOS development. I will try your suggestion on the sample apps(for Unity 5 and maybe Unity 4.5 to make sure).

Unity 5

March 19, 2015 - 2:31am #13

You may want to first try the Smart Terrain sample app, or the Penguin Sample app (both use Smart terrain feature), as those are already correctly setup.

You may use Vuforia 4.0 with the Windows 32 bit version of Unity 5, but not on Mac (which requires a 64bit version).

 

 

 

Unity 5

March 19, 2015 - 12:58am #12

Recently upgraded to Unity5 and this is the first time ivé tried vuforia. I'm attempting to use extended tracking but it isnt going so well. It just doesn't seem to work, target still gets "lost". im not sure if i missed something (I just ticked the checkbox for extended tracking on my image target, i only have 1 target) or if its because vuforia doesn't support unity5 yet. What do you think? Any advice would be appreciated.

 

PS. im reinstalling Unity4.5 , gonna have both versions. and im using MAC :) 

Unity 5

March 15, 2015 - 3:48pm #11

dear AlessandroB

 

   when will   vuforia officially support unity 5 ?      next week  or next month ?

Unity 5

March 13, 2015 - 1:57am #10

You can ignore that error, or you can simply remove  the ExtensionImport.cs script; that script simply attempts to set the Player Settings automatically, but it is not required to build and run Vuforia, as long as you set the correct Player Settings for Android and/or iOS in the Player Settings panel before clicking "Build and Run", i.e. (as I previously posted):

For iOS:

- set the Graphics API to OpenGL ES 2.0

- set the Scripting Backend to IL2CPP

- set the Architecture to Universal

For Android:

- set the Graphics Level to OpenGL ES 2.0

- set the Device Filter to ARMv7

Unity 5

March 13, 2015 - 1:16am #9

this is why,   unity 5.0  + vuforia 4.0

Assets/Editor/QCAR/Scripts/ExtensionImport.cs(37,41): error CS0117: `UnityEditor.PlayerSettings' does not contain a definition for `targetIOSGraphics'

 

 

Unity 5

March 10, 2015 - 7:39am #8

Unity 5 on Mac 64 is officially not supported yet (in Vuforia 4.0),

however

you may still use Unity 5 on Mac (64bit), although with some limitations;

this will not run in Play Mode (and you will see some error messages in the Unity console), and some of the Editor functionalities may not work,

but you may be able to deploy a project on iOS by selecting iOS in the Build Settings and click Build and Run:

some notes: in the iOS Player Settings, make sure to:

- set the Graphics API to OpenGL ES 2.0 (Automatic / Metal are not supported by Vuforia 4.0)

- set the Scripting Backend to IL2CPP

- set the Architecture to Universal

 

 

 

Unity 5

March 5, 2015 - 2:40am #7
Well, I could not find Unity5 (32 bits) for MacOSX.... ((((
How can I build for IOS now?

Unity 5

March 4, 2015 - 8:45am #6

Yes, definitely we are looking at that, but no ETA available at the moment.

Unity 5

March 4, 2015 - 8:08am #5

Do you guys have any plan for updating to Unity 64-bit or no? so we can use unity5

Unity 5

March 4, 2015 - 1:47am #4

+1, it's preventing us from upgrading to Unity5

Edit: just saw the post below, thanks! will take a look :)

Unity 5

March 4, 2015 - 12:11am #3

Vuforia 4.0 does not support the 64bit version of Unity 5.

If you are working on Windows, you can however download the 32-bit version of Unity 5:

once you land on the Unity download page,

you should see a dropdown menu with title "Additional Downloads" and sub-header "For Windows"; for there you can download the 32bit version called "Unity Editor (32bit)".

 

Some notes about Vuforia 4.0 and Unity 5:

  • Vuforia 4.0 may not work on the Mac OS (64bit) version of Unity 5
  • Vuforia 4.0 may work on the Windows 32 bit version of Unity 5; this should cover the use of Play Mode and the ability to build and deploy your app on Android devices.

 

We are currently testing Vuforia 4.0 with the Windows 32 bit version of Unity 5, and we will post an update as soon as we have more confirmed results.

From our initial assessment, here are a set of Build Settings / Player Settings you'll need to set when building and running on Android:

  • Under Player Settings > Resolution and Presentation:  set the device orientation to the desired value (e.g. Portrait, Landscape Left, Autorotation, .....)
  • Under Player Settings > Other Settings:
    • Graphics Level: set it to "Force OpenGL ES 2.0" (by default Unity 5 sets this to "Automatic")
    • Device Filter: set it to ARMv7 (by default Unity 5 sets this to "FAT (ARMv7 / x86)")
    • Android TV compatibility: set it to OFF (i.e. uncheck the checkbox)

 

Other known issues (at this time):

VideoPlayback sample:

you may see a compiler warning when building the VideoPlayback sample:

UnityEditor.EditorUtility.UnloadUnusedAssets is obsolete

this warning should be harmless; however, you can remove it by simply replacing the call to UnityEditor.EditorUtility.UnloadUnusedAssets with UnityEditor.EditorUtility.UnloadUnusedAssetsImmediate() in the VideoPlaybackEditor script code.

 

 

 

 

Unity 5

March 3, 2015 - 7:37pm #2

Same problem here!

Topic locked